Windows 10 website, DFO reported as unsafe

drummerbill

DFO Master
Joined
Nov 28, 2006
Messages
5,305
Reaction score
194
Location
NY-NJ Tri-state Area
This website has been reported as unsafe

www.drumforum.org

I am running AVG security and did a spybot scan. Site opens clean, then I continue to get the red screen with the pop -up. What gives ? Mods ?
 

fun2drum

Team DFO
Staff member
Moderator
Joined
Jun 6, 2012
Messages
6,354
Reaction score
250
Location
Western North Carolina
That's interesting. I run Windows 10 in several PC's with Trend Antivirus and no warnings have ever popped up. Maybe Ben and/or Mike can chime in with something more helpful.
 

swarfrat

tympanus laqueus XV
Joined
Dec 15, 2014
Messages
5,405
Reaction score
591
Another forum I once frequented had problems with Google ads which were unsafe. I'm guessing that might be the same underlying cause here.
 

Olderschool

DFO Veteran
Joined
Apr 26, 2016
Messages
1,835
Reaction score
320
Location
Usa
I started experiencing the same warning two days ago. I had to disable Windows Smartscreen to prevent it. I'm running Edge.....
 

drawtheline55

Owner/admin
Administrator
Moderator
Joined
Jan 31, 2011
Messages
3,739
Reaction score
235
Location
Boston
Don't know, I don't use windows, I use Mac, never had anything like that pop up.

I wouldn't assume it is the site just because windows says so, I would check with them if you can.

Ben
 

TDM

Yapping Internet Mutt
Joined
Oct 28, 2010
Messages
5,445
Reaction score
402
rondrums51 said:
It's Windows 10 that's unsafe. The thing is crap.
Precisely. It's worse than crap. It's spyware, adware, and malware. We've entered an age where customers need to be equally concerned about what large, established IT companies do to scam our information and use it to make hidden and profits. We're not customers to these companies anymore. We are prey.
 

TDM

Yapping Internet Mutt
Joined
Oct 28, 2010
Messages
5,445
Reaction score
402
drummerbill,

I'm on Windows, but not Windows 10. No warnings here. I use Adblock and a tracking protector (which eliminates even more malicious scripts and advertising).

Never had DFO reported as a malicious site on any computer, however, I realize these things can change. I don't see advertising on DFO and have never seen advertising on DFO. Mind you, for years, I had no idea there is advertising on YouTube because my computer blocks all of it. It wasn't until I saw YouTube at a friend's house and I asked "what's that" that I realized YouTube spams users with ads. We were waiting for a 30 second ad to finish so we could watch a video. These ads are completely blocked by my computer and always have been.

It's possible your Windows 10 configuration is allowing malicious advertising through and your anti-virus is catching this. To the best of my knowledge though, DFO doesn't have ads. Hmmm. Interesting. It could be a problem with the company hosting DFO. I've had this occur. One moment a site is fine. The next moment, due to problems with the hosting service, all sites hosted by that service are reported as malicious. Another possibility. Your anti-virus software momentarily has an erroneous listing for DFO. I've had this happen with other sites. (The site is fine and it's the anti-virus software that is the problem.) Still, in general, I am not encouraging you to ignore warnings. Investigate them and use reasonable judgement, for sure.
 

burgundy

Very well Known Member
Joined
Jul 28, 2015
Messages
688
Reaction score
58
Location
n.b. canada
I had same problem a while back with windows 7, had it today with windows10, switched from rogers yahoo to google, cleared it right up?
 

TheBeachBoy

Ringo Fire
Joined
Aug 5, 2005
Messages
7,693
Reaction score
339
Location
Phoenix, AZ
I run Win 7 and started using a Chrome plugin called ScriptSafe. It's kind of a pain at first, but once you "allow" your most frequented websites, it blocks unwanted ads and videos. I use that with an ad block plugin and rarely get popups and definitely get less spyware or malware.
 

drummerbill

DFO Master
Joined
Nov 28, 2006
Messages
5,305
Reaction score
194
Location
NY-NJ Tri-state Area
Turned off smartscreen,still getting the warning page. If I use chrome then I don't get the warning.
This is the only site of many I use that I repeatedly get this warning. Ugh.
 

drummerbill

DFO Master
Joined
Nov 28, 2006
Messages
5,305
Reaction score
194
Location
NY-NJ Tri-state Area
Thanks mods....I think. Got home from the "City of Brotherly Love" and everything is working as usual with Windows IE !!!!! :)
Have a great weekend kids !!
 

Olderschool

DFO Veteran
Joined
Apr 26, 2016
Messages
1,835
Reaction score
320
Location
Usa
Still getting warning. Here is a screenshot (I had to disable smartscreen in order to even access the site)

Windows DFO Warning.jpg
 

blueshadow

Just Shuffling along
Staff member
Moderator
Joined
Aug 5, 2005
Messages
13,135
Reaction score
994
Location
North of Austin, Texas
I was getting the error message but not now, only thing I did was report it safe through the Microsoft "feedback" that displayed on the message, not sure if that corrected the issue or what??? but anyways all good here with Windows 10
 

Latest posts



Top